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Overview 

 In the next hour, ESRD will cover the 

following best practices: 

• General meshing guidelines for singularities 

• Crack automeshing in 2D/3D 

• Extraction of SIF in 2D/3D 
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StressCheck Hints & Tips 

Meshing Overview & Best Practices 



Topics 

 Meshing in StressCheck 
• Element Library 

• Element Associativity 

 General Meshing Guidelines 
• Vertex Angles 

• Category A Problem Mesh Strategy 
 Solution Analytic Everywhere in Domain 

 No discontinuities in geometry or boundary conditions 

 Examples of Meshes for Category A 

• Category B Problem Mesh Strategy 
 Solution Analytic Everywhere Except in Finite Number of Locations 

 Discontinuities in geometry or boundary conditions exist 

 Re-entrant corners and/or point loads 

 Examples of Meshes for Category B 
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StressCheck Meshing Overview: 

Element Library 

 Simple element library based only on topology:  

• Quadrilaterals, Triangles 

• Beams, Fasteners, Links 

• Contact Regions 

• Hexas, Pentas, Tetras 

 

esrd, inc. 5 

Tetra automesh 

Beam elements 

Triangles 
Fastener Contact Regions 
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StressCheck Meshing Overview: 

Element Associativity 

 Elements are geometrically associative. 

 Associativity determined by node creation. 
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2 curved edges 

2 curved edges 

Nodes created as projection  

on the circle. 

Nodes created as offset  Node created at intersection 

Node created 

at a point 
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General Meshing Guidelines:  

Vertex Angles 

 Triangles, Pentahedral and Tetrahedral elements 

• Vertex angles as close to 60 degrees as possible. 

 Quadrilateral and Hexahedral elements 

• Vertex angles as close to 90 degrees as possible. 

 Practical limits: 10° < Vertex Angles < 150° 
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Ideal Acceptable Not recommended 
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General Meshing Guidelines: 

Category A Problem Mesh Strategy 

 For problems in Category A, uniform meshes are 
optimal. 
• Describe boundaries with smoothly connected fillets. 

• The number of elements is controlled by the geometric 
complexity of the part. 

• Place nodes at boundary points where the curvature 
changes abruptly. 

• Place nodes along boundaries to create curved elements 
using options: offset, intersection, mid-offset, projection. 

• If the solution is not acceptable for the highest p-level, 
increase mesh density in region of interest and repeat p-
extension. 
 Use h-refinement tools if applicable (manual meshing only). 
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General Meshing Guidelines: 

Category A Problem Mesh Examples 

 Hand-meshes are shown for concept 

 Note that fillets are used for transitions 
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General Meshing Guidelines: 

Category B Problem Mesh Strategy 

 For problems in Category B, geometrically graded 
meshes are optimal. 
• The diameter of elements should decrease in 

geometric progression toward singular points with a 
common factor of 0.15. 

• One or two layers of geometrically graded elements 
around singular points is typically sufficient. 

• Elsewhere the size of elements is controlled by the 
geometric complexity of the part. 
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General Meshing Guidelines: 

2D Category B Problem Mesh Example 

 Example of 2D-meshing with refinement  
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Lap-joint specimen 

Geometric progression 

Common factor 0.15 
Two Discontinuities: 
Material and Geometric 
(Adhesive/Metallic 
Interface and 90 
degree angle) 09/12/2012 



General Meshing Guidelines: 

3D Category B Problem Mesh Example 

 Example of 3D-meshing with refinement: 
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12 

a 

0.15a 

0.152a 

Tan Color Elements Show 
the Crack Face Size 

Cracked Channel 
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General Meshing Guidelines: 

3D Category B Problem Mesh Example 

Corner Crack  

Poor Automesh 

Corner Crack 

Ideal Automesh 

esrd, inc. 13 

0.25 
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Boundary layer 

refinement based 

on 0.15 factor of 

crack length 0.25 



Summary and Conclusions 

 The control of discretization, or approximation, 
errors is simple when p-extensions are used with 
properly designed meshes. 
• Determine a priori if the mesh for the problem at hand 

should be designed for Category A or Category B.  

 It is important to produce accurate representations 
of the domain and boundary conditions so that 
these potential sources of error do not affect the 
accuracy of the data of interest. 
• Improper boundary conditions can lead to problems 

for which the exact solution does not exist or is 
trivially zero. 
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StressCheck Hints and Tips: 

Crack Automeshing in 2D and 3D 



Automeshing Cracks in 2D 

 Basic Process: 
• Produce a valid sheet 

body 

• Generate curvature 
representing crack 
shape 

• Imprint curvature 
representing crack in 
sheet body 

• Specify resulting 
curvature as a “Crack 
Edge” in automesher 
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Automeshing Cracks in 2D 

 Sheet Body: 

• Change reference to 

“Planar” 

• Go to the “Geometry” 

tab in “Model Input” 

• Use “Create->Plane-

>Locate” 

• Enter values as shown 

in image on right 

• Click “Accept” 
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Automeshing Cracks in 2D 

 Crack Shape: 
• Change to “Curve” 

selector 

• Use “Create->Spline-
>Locate” 

• De-activate inputs 

• Left click within the plane 
domain several times 
until general curvature 
results 

• Double-left click outside 
domain (see image on 
right) and click “Yes” to 
create the spline 

09/12/2012 esrd, inc. 18 



Automeshing Cracks in 2D 

 Imprint Curvature on 

Plane: 

• Change to “Surface” 

selector 

• Use “Create->Body-

Imprint->Curve 

Normal” 

• Select the Plane 

• Select the spline 

• Press Accept 
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Automeshing Cracks in 2D 

 Specify curvature as 
“Crack Edge”: 
• Click on the “Mesh” tab 

• Use “Create->Mesh->Auto” 

• Select sheet body 

• Click “Accept” 

• Use “Create->Mesh-
>Crack Edge” 

• Select the imprinted curve 

• Click “Accept” 

• Click “Automesh” 

• Use “Check->Edge->Free 
Edge” 
 Crack highlights red 
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Automeshing Cracks in 2D 

 Refinement at Crack Tip: 
• Delete all mesh records 

• Need to create a boundary layer 
with a circle 
 Go to the “Geometry” tab 

 Use “Check->Point->Distance” 
 Check crack length 

 Use “Select->Point->Locate” 

 Click on the “Index” tab 

 Locate “Offset” point and click on 
list item 

 Click “Blank” 
 Don’t want to allow picking 

 Toggle to “Curve” selector 

 Use “Create->Circle->Point” 

 Activate radius, type 0.15*crack 
length 

 Click on crack tip point 

• Now, imprint the circle and re-
mesh, making sure to select 
each segment of the crack 
curvature 
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Automeshing Cracks in 3D 

 Basic Process: 
• Produce a valid solid 

• Generate a surface 
representing the crack 

• Embed the surface in the 
solid using Boolean-
Union 

• Specify the now 
embedded surface as a 
“Crack Face” in the 
automesher 

• If available, use 
Boundary Layer 
automesher 
 Otherwise, use surfaces 

as boundary layers 
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Automeshing Cracks in 3D 

 Solid Body: 

• Set reference to “3D” 

• Go to the “Geometry” 

tab in “Model Input” 

• Use “Create->Box-

>Locate” 

• Enter values as shown 

in image on right 

• Click “Accept” 
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Automeshing Cracks in 3D 

 Crack surface: 

• Use “Create->Ellipse-

>Locate” 

• Enter values as shown 

in image on right 

• Click “Accept” 
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Automeshing Cracks in 3D 

 Embed crack: 

• Use “Create->Body-

>Bool-Union” 

• Select the solid 

• Select the surface 

• Click “Accept” 
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Automeshing Cracks in 3D 

 Automesh crack with “Crack 
Face”: 
• Click on the “Mesh” tab 

• Use “Create->Mesh->Auto” 

• Click on the solid 

• Click “Accept” 

• Use “Create->Mesh->Crack 
Face” 

• Turn off curve display 

• Turn on wireframe display 

• Select boundary of embedded 
surface (top right) 

• Click “Accept” 

• Use “Create->Mesh->Bndry. 
Layer” 

• Turn on curve display 

• Turn off surface display 

• Select ellipse (bottom right) 
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Automeshing Cracks in 3D 

 Automesh crack with 

“Crack Face” (cont.): 

• Enter values as shown 

in image on right 

• Click “Accept” 

• Click “Automesh” 
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StressCheck Hints and Tips: 

Fracture Mechanics Extractions 



Selection of Contour Integral Radius 

for SIF Extractions 

 Planar reference: 

• Computation of SIF by CIM is theoretically 
path independent, so the selection of 
integration radius is in general arbitrary 
 A practical size for the integration radius must be 

chosen such that it lies within domain 

 This independence can be proven by extracting 
SIF for several integration radii 

• Additionally, it is not always necessary to 
include layers of refinement to obtain low 
error in the SIF 
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Example Planar Problem 

 “mura5_11” from “2D-

Fracture” Handbook 

 No refinement at the 

crack tip 

 Solve Linear p=1 to 8 

 Go to the “View 

Results” interface 

 Click on the 

“Fracture” tab 
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Example Planar Problem 

 Turn on node display 

 Turn on curve display 

 Use “Select->Node->SIF” 

 Use Runs 1 to 8 

 Left click and drag outward 
from the crack tip node 
• Radius will be calculated by 

motion 

 Release left button 
• Integration circle will be drawn 

• SIF will be computed 
automatically 

 Try several other radii and 
compare to SIF 
• Values should remain stable, 

within 1% 
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Selection of Contour Integral Radius 

for SIF Extractions 

 3D reference: 
• Computation of SIF by CIM is NOT path independent, so care 

must be taken in the mesh design and selecting the integration 
radius 
 Most particularly for curved cracks 

• Best: geometrically graded layers of refinement around crack tip 
using a factor of 0.15 and based on the characteristic length (i.e. 
crack size) 
 Two is usually recommended 

 The reason for using layers of refinement graded in geometric 
progression towards the singular point is to distribute the error evenly 
on the elements in the vicinity of the crack tip  

• Best: selection of integration radius should be such that it is just 
outside of the innermost layer of refinement 
 Using an integration radius as small as possible will decrease the 

influence of adjacent points when computing the SIFs 

 A best practice is to extrapolate integration radius to zero 
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Example 3D Problem 

 “SurfaceCrackCSHole.s
ci” in “3D-Fracture” 
Handbook 

 Note two layers of 
geometric refinement 
around crack (pink) 

 Solve p=1 to 6 

 Go to the “View 
Results” interface 

 Click on the “Fracture” 
tab 
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Example 3D Problem 

 Use “Select->Node->SIF” 

 Use Runs 1 to 6 

 In the “Radius” field, enter 
“0.03*a” 
• Since first layer is “0.0225*a”, 

want to enter radius just outside 
first layer 

 Turn on curve display 

 Turn on wireframe mode 

 Select an element edge on the 
crack front 
• SIF should be automatically 

extracted 

 Change integration radius to 
“0.025*a”, and click “Accept” 
• Note the change in value 

• Can use several more values to 
extrapolate to R->0 
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Computing SIF distributions on 

crack boundary 

 Load the handbook 
problem 
“3DLugCornerCrack.sci
” from Fracture 

 Go to the “Compute 
Solution” interface 

 Click on the “Linear” tab 

 Enter p-limits “4” to “6” 

 Click on the “SOLVE!” 
tab 

 Click “Solve” 
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Computing SIF distributions on 

crack boundary 
 Go to the “View Results” interface 

 Click on the “Points” tab 

 Use “Select->Any Boundary” 

 Use Runs 1 to 3 

 For “Func(s):”, select “K1” and 
“K2” 

• Hold CTRL to select both 

• “Rad:” will appear for input of 
contour integral radius 

 For “Rad:” enter “0.03*a” 

 For “# of pts.”, enter “20” 

 Change “Sys:” to “SYS9” 
• Can extract the angle 

 Select the curve representing the 
crack front 

 Click “Accept” 

 Note that not all locations were 
computed 

• This is common for curved cracks 
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Computing SIF distributions on 

crack boundary 
 Why does this happen? 

• Inverse mapping failure 

• Most common for 
automeshed tetrahedra 

 What is the solution? 
• Use the element edges 

instead 

• Change to “Select-
>Edge Curve” 

• Select an element edge 
on the crack front 

• Reduce “# of pts.” to “10” 

• Click “Accept” 
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Thanks! 

support@esrd.com 
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